7 posts
  • Has been part of the Envato Community for over 6 years
jacek says

Hello,

I have my Video Player in root directory and everything is fine. But when I move files (directory elite_video_player_xml and file elite_video_player.swf) into another folder, my Video Player doesn’t work

For example:

Its OK:

www/elite/elite_video_player_xml

www/elite/elite_video_player.swf

Its NOT :

www/elite/movies/elite_video_player_xml

www/elite/movies/elite_video_player.swf

Of course I also change proper XML config file with a new path. What should I do?

PS: Sorry for my English

Thank you for answer:-)

903 posts
  • Has been part of the Envato Community for over 7 years
  • Has referred 500+ members
  • Has sold $40,000+ on Envato Market
  • Interviewed on an Envato blog
+4 more
Flash_Cart says

Great question, usually it’s because the XML content is loaded into the flash movie through the file structure.

e.g. “load.xml=/www/elite/elite_video_player_xml.xml”

So, if you change the folder name or move folders around, they won’t work properly.

Now, consider the fact that I have not seen the file, however this general info should still apply.

129 posts
  • Has been part of the Envato Community for over 6 years
  • Has collected 10+ items on Envato Market
SpiderFX says

Where is the Video that you are playing located?

Most of the files that I have worked on from Flashden, the action script points to the xml within the same directory and not the full url, so simply moving all the contents from one folder to another normally does not matter, but what does matter is how you point to the video file, if you made no change to the xml script when you moved it, it probably wouldnt work, if you did make a change, make sure that it was correct. I would put in the fully qualified url tot eh video path just to see if it was working correctly i.e. http://www.yoursite.com/video/myvideo.flv in your xml file.

905 posts
  • Has been part of the Envato Community for over 7 years
  • Has collected 100+ items on Envato Market
  • Located in United States
unchartedrealms says

I use the elite template and when I move xml files I have to open the fla of the section I am working on and go into the config actionscript and the functions and look for links to the xml and then change them to the corret directory paths.

7 posts
  • Has been part of the Envato Community for over 6 years
jacek says

@SpiderFX I checked with fully qualified url and it’s not working, its so strange :-| Do you have another idea?

@unchartedrealms Could you tell me how and where I can find link to that xml file? I know I should run fla in Adobe program but what else? Where is this config action script? I tried to find it but I’m not very good in this program.

Thank you very much for any help:)

905 posts
  • Has been part of the Envato Community for over 7 years
  • Has collected 100+ items on Envato Market
  • Located in United States
unchartedrealms says

yea open the elite video player .fla file inside of adobe flash. Look at your layers in your timeline and look at the layer named config and the layer named functions. Open your Actions panel through the top menu item widows or hit the function key f9 to open the actions panel. With the actions panel open look click on the frame in the timeline that is labled config. At this point you should be scanning through code triworks wrote in the actions panel. YOu are looking for the line that looks like the file name of your xml file. you can do a search of the actions panel by hitting control f and then pasting in the text string you are looking for . hope this helps. you need to find it in the functions keyframe as well. hope this works for you.

7 posts
  • Has been part of the Envato Community for over 6 years
jacek says

@unchartedrealms

Working!!

Thank you very much <\beer> ;-)

by
by
by
by
by
by